"Read More" Translation

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #23208
    aurorebelle42
    Participant

    My website is in french language and I’d like to translate into french the text:

    • “Read More” on the slider
    • “Continue Reading” on the blog page

    Thank you for your help,
    Aurore
    http://2aleanconsulting.com/

    #23222
    aurorebelle42
    Participant

    Hi,
    I have one more question:
    Where can we change the color of the text that appear on the Slider.
    The Article title and the link “Read More” are in white color. How to change it to black?
    Thank you very much!

    Best regards,
    Aurore

    #23226

    Hi aurorebelle42,

    Where can we change the color of the text that appear on the Slider.
    The Article title and the link “Read More” are in white color. How to change it to black
    ==> We are sorry about it. This feature is not available in free version of our theme.

    To translate in your language “Read More” and “Continue Reading”, you have to create a .po and .mo file from poedit.Before adding this file create a child theme to be safe from data loss while updating to our new version.

    Thank you!

    #23580
    micke
    Participant

    Hi!

    I’m confused… Added a folder “languages” in my child theme directory and added sv_SE.mo/.po for my Swedish translation. But the file is never loaded. Also tried to name it “ultimate.mo/.po”, same as the English original. But doesn’t work either.

    What is the correct path/file name? Thanks!

    #23624

    Hi micke,

    Did you add this code inside you functions.php file.
    load_theme_textdomain( 'ultimate', get_stylesheet_directory() . '/languages' ); // to add text domain language translate

    If there is still problem then you may send it to us at below link. We will add your language file so that you don’t need to create any childtheme for language translation.
    Email Us

    Thank you!

    #23631
    micke
    Participant

    Hi

    Still not working. My files in childtheme/languages are named “ultimate.po” and “ultimate.mo” while your file is named “ultimate.pot”

    When I echo this the path is correct:sprintf("%s/languages", get_stylesheet_directory())

    Wordpress is 4.1.1 Swedish version, still not able to get the translations from my own file.

    Do I have to reactivate the theme or something after adding the row to functions.php?

    Pls advise,

    #23657

    Hi micke,

    You don’t need to reactivate the theme. Once you activate the child theme then it must work fine. Use sv_SE.mo and sv_SE.po file and keep these file inside the language folder. Use this code inside child theme of functions.php that i have provided before
    load_theme_textdomain( 'ultimate', get_stylesheet_directory() . '/languages' ); // to add text domain language translate
    Just have this link
    http://www.wpbeginner.com/wp-themes/find-translate-translation-ready-wordpress-theme/

    You may also visit to this site and its working fine.
    http://www.scmarinhense.pt/category/institucional/

    Thank you!

    #23663
    micke
    Participant

    Thanks, that did it! Just renamed the files and reloaded the site.

    I’ll send the Swedish translation once it’s 100% completed.

    Thank you!

    #23681

    hi micke,

    Thanks for sending Swedish translation. Once we will check it and update it in our new version.

    Thank you!

    #24863
    fcukcsd
    Participant

    Hi,

    translating “read more” is above my skills. How can I remove “reade more” box from slider?

    Thank you for your help,

    #24880

    Hi fcukcsd,

    Go to Appearance -> Theme Options -> Design Options Tab -> Custom CSS paste the following CSS code and Click on save all changes button:
    themehorse.com/media=”all”

    .call-to-action {
      display: none;
    }

    Hope this may help you!
    Thank you!

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.