Nav Menu auto-generates with all pages (primary navigation padding issue?)

This topic contains 5 replies, has 2 voices, and was last updated by  Theme Horse Support Team 7 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #54207

    mgeders
    Participant

    I made a menu and pointed it towards the top right section navigation. However, another menu appears under that (below the site title and tagline) and appears to be just a list of every page on the site. I can’t figure out why this is showing up or how to turn it off. I’ve been tweaking a few things so the only thing I can think of is something was cached somewhere but I flushed that. If I toggle the top right and primary, then the massive list gets replaced correctly, but now I have a duplicate menu. I really like the menu in the info bar because the padding of the primary location is too much (I don’t use a site title and tagline as I have a header image that does that). Any ideas?

    ETA: If I create a menu with nothing in it and assign it to the primary location it “works”, but I guess I just don’t like the padding. How do I fix that?

    #54226

    Hi Mgeders,

    Yes you have to create a menu with nothing and assign it to primary. If not set all the pages will be listed as default menu item.
    If you want to reduce the padding just make it clear which space you want to reduce so that we can provide you a exact css code to reduce it.

    Thank you!

    #54245

    mgeders
    Participant

    So I realized that having the primary navigation on the top right of the status bar doesn’t allow for sub pages to appear when hovering over those nav items so I’ve re-enabled the primary navigation menu since it includes this feature (and disabled it from top right). I’ve hid the site-logo per below and and it helped. I originally hid the hgroup-wrap but discovered that this effectively hides the menu when viewing it on mobile or reactive sizing.

    Is there a way to reduce or hide that space and still have the mobile/reactive menu function properly?

    #site-logo {
    display: none;
    }

    Also, I was playing around with a WooCommerce store pages and couldn’t get a right column to show up. I assume I’d have to buy the pro version for this to work?

    #54321

    Hi Mgeders,

    Just add below custom css code to hide the hgroup-wrap in desktop view and display it on mobile devices.

    .hgroup-wrap {
            display: none;
        }
    @media only screen and (max-width: 767px) {
        .hgroup-wrap {
            display: block;
        }
    }

    Also to have the right column sidebar for wooCommerce store page just go to Appearance > Customize > Magcast Theme Options
    Layout Options
    there you can see the content layout. Choose Right Sidebar option and Click Publish Button.

    Thank you!

    Regards,
    Theme Horse

    #54332

    mgeders
    Participant

    Thanks.

    This may be more of a WP/Woo question, but setting the right column sidebar as you’ve described overrides all other pages. I can set that style individually for each page under that pages options, but it appears that WooCommerce pages go exclusively by what is set in the Appearance > Customize > Magcast Theme Options > Layout Options. Can you confirm this is as intended?

    In other words, I can’t set the default to something else and change only the WooCommerce page in that pages settings.

    #54363

    Hi Mgeders,

    Actually WooCommerce Shop page is an archive page and the layout settings that we have in the pages only reflect to pages only.
    And the layout for this archive page will be set via customizer only.

    Thank you!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.