Biggest Sale! Special Offer!

Get 30% discount on all of our single themes with this coupon code: #30%SALE

Hurry up! *Limited time offer*

Full content on home page

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #10148


    How do I display full content on my posts on the home page? At the moment, it just shows the except and I cannot seem to turn it off. I’ve read the theme instructions, but I am none the wiser. It talks about selecting a template from a drop down menu, but I can’t see any template menu. I am converting from another wordpress theme into attitude-pro and have posts on my site already.

    I would be grateful for some clear, step-by-step instructions (your theme instructions are not clear). Usually, I am relatively tech-savvy, but this has defeated me.

    Also, is there a way of searching this support forum? If I have further questions in the future, it would be useful if I could see if they’ve been asked before.



    A new day and taking a second look at this…

    I have managed to do, as it says, in the instructions and set up a blog page with full content by starting a new page. I found the template drop down in the end. It is in page attributes, which is visible by going into screen options at the top of the page.

    So, i have set up a page for my blog, chosen full content, but this does not display on , home page. I even went to customisation and selected that as a static page for my home page. It still does not display on my home page site.

    To see what I mean, I am at:



    hi Jane
    We are sorry. For the home page only the blog image large post will be displayed. To display the full content you need code customization for it. We have designed our theme this way.
    Before customizing code you need to make child theme and customize the code otherwise all your customization code will be lost while updating to our new version.
    Thank you


    What would be the customisation code for that? Without being able to display the full content on the home page and pictures, the theme is pretty useless.

    By using excerpts, WordPress strips out all the formatting of the posts and doesn’t display any pictures (“featured image” doesn’t work as it squashes all images into squares).

    I have already implemented a child theme.

    I am happy with the way the blogs are displayed if I set up a “blog image large post” template. But I need that to appear on the front page of the site.


    Ok… success!!

    What you have to do is go to Settings >> Reading settings. There, set “front page displays” to whatever you’ve called your blog page which you’ve set to display full content. This does the trick! You cannot do it from the Customisation page, even though there appears to be that option there (it doesn’t work).

    I did a bit more Googling and found this out myself. The key to doing it was in this post;

    So why did your support team claim that it cannot be done, the theme isn’t written this way and I would have to hire a developer (having already paid for support from Themehorse). I think this is poor support.

    It’s a shame because now that I’ve implemented this change, my site is looking a lot better.


    And also on that settings >> reading page, ensure that “for each article in a feed, show…” has ‘full content ticked.

    I make note of these steps for other people looking to solve a similar issue.


    Ok thanks that’s great and also sharing some of you help to us.
    Thank you Jane

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.