Contact Us plug in shows contact form on all pages

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #3215
    Hp
    Participant

    I followed the instructions for adding the contact us form and it shows up on home page instead of just the contact page. I am using business theme. How do I add a contact/sign up page that only has the contact us form on that one page? Thanks

    #3226
    Rabin Shrestha
    Participant

    Can you post link to your site? Are you using contact form 7 plugin or something else?

    Rabin

    #3276
    Hp
    Participant

    Yes, it is contact form 7. I would like to have a page that is a sign up/ contact us layout as you have in the demo. Every time I activate the sign up/contact us page it populated the home page with the contact us form. I’ve followed the directions in the installation. I can send you screen shots
    https://www.dropbox.com/sh/vhxqeq0dnul1jhm/DDaM9HFV9p

    #3288
    Rabin Shrestha
    Participant

    Hi Hp,

    It’s difficult to figure out the issue just seeing the screenshot. We have not be approached by such issue till now and doesn’t seem to be our theme specific issues. Probably some plugins may create such conflicts try to deactivate the plugins and see if it makes any change.

    Rabin

    #3304
    Hp
    Participant

    I’ve followed the theme instructions with the plug in recommended by Themehorse. Can you please help? I just want a contact page to look like the demo. The screenshots are home page before, the page set up per instruction, and the home page after. It’s pretty understandable what happens from the screenshots, nothing complicated. I deactivated and reinstalled the plug in you say to use and still have the issue of the contact form showing on the home page instead of it’s own page. Please advise. Thanks.

    #3306
    Hp
    Participant

    I’ve discovered that the addition of a page to my site creates the same issue- with ot without the contact form plug in. ANy page I add defaults to showing on the home page of my site. Please help. Thanks

    #3361
    Rabin Shrestha
    Participant

    Go to Settings->Reading->Front Page displays->A static page (select below) and make sure contact us page is not selected on Front page. Other than this I don’t see any other reason of contact us being home page.

    Rabin

    #3430
    Hp
    Participant

    Thank you very much for your time.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.