Biggest Sale! Special Offer!

Get 30% discount on all of our single themes with this coupon code: #30%SALE

Hurry up! *Limited time offer*

Cannot remove Slider from Blog Page


Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #17322


    I am having trouble with the slider appearing on the home page and the blog page.

    I have set the homepage to ‘Business Template’ and the slider shows perfectly.

    I have set the blog page to ‘Default template’ with ‘No sidebar, Full Width’ checked – yet the slider is still showing.

    None of the other pages (also Default and No sidebar, Full Width selected) are showing the slider.

    Am I missing something? Thanks in advance 🙂



    You just need to disable slider from theme options > Featured Post/Page Slider > Slider options …..

    If you are looking for any other thing…please post here, my reply is for disable slider from home/front page.



    Hi harryyeah,
    You just go to the dashboard -> setting -> reading -> front page display (home -> its correct)
    front post page (–select– (leave it to default. Don’t assign to any page))

    So that the silder will be displayed only in your home page.

    Thank you!



    I was having the same issue. Doing the first fix listed disables the entire slider. Doing the second fix removes the blog post functionality of the dedicated blog page. None of my posts display on the blog page when I leave the ‘posts page’ undesignated. I want the slider on the home page only but need to keep the blog running.



    hi kirchmke,
    To activate the blog page you just create a page to display. At the right side there is template. You can choose any blog template. There is three blog layout. If you select the blog template then you will be able to display the blog page with no slider. But inside setting ->reading -> front page display -> post page (leave it to default –select–)

    Hope this may help you

    Thank you!


    Thanks for the info! That worked like a charm! I had the blog post page set to one of the blog templates but it wasn’t displaying properly without the post page set to default. Thanks, again, for your help!


    ok that’s great kirchmke

    Thank you!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.